[原创源码]查询QQ群资料以及点亮QQ手机端CF图标源码
侧边栏壁纸
  • 累计撰写 69 篇文章
  • 累计收到 2,866 条评论
  • 今日撰写 0 篇文章
    今日已经过去 16 小时
    69%
    这周已经过去 1
    14%
    本月已经过去 22
    70%
    今年已经过去 8 个月
    66%
[原创源码]查询QQ群资料以及点亮QQ手机端CF图标源码
2022年11月06日427阅读10评论1点赞
苏晓晴
发布时间:2022年11月06日 / 10 / 427 / 正在检测是否收录...
温馨提示:
本文最后更新于2022年11月06日,已超过484天没有更新,若内容或图片失效,请留言反馈。

注意事项

本源码获取的skey以及pskey存活时间为两个小时
两个小时后将会自动失效 如果出现获取失败 请更新这两个值!

主要接口

点亮CF图标 https://club.vip.qq.com/api/trpc/cf/SetSwitchStatus?g_tk=计算pskey获得gtk/btn值

查询QQ群资料 https://qinfo.clt.qq.com/cgi-bin/qun_info/get_group_info_v2?gc=群号&bkn=计算skey获得gtk/btn值

计算gtk/btn源码

def get_gtk(p_skey):
 hash=5381
 for i in p_skey:
  hash += (hash << 5)+ord(i)
 return hash & 0x7fffffff
print(get_gtk('123456'))

{
   var hash = 5381;
   for (int i = 0, len = skey.Length; i < len; ++i)
   hash += (hash << 5) + (int)skey[i];
   return hash & 2147483647;
}

function getbkn($skey) {
    $len = strlen($skey);
    $hash = 5381;
    for ($i = 0; $i < $len; $i++) {
        $hash += ($hash << 5 & 2147483647) + ord($skey[$i]) & 2147483647;
        $hash &= 2147483647;
    }
    return $hash & 2147483647;
}

.版本 2

.子程序 计算bkn, 文本型
.参数 Skey, 文本型
.局部变量 基值, 整数型
.局部变量 计数, 整数型
.局部变量 长度, 整数型
.局部变量 结果, 整数型

基值 = 5381
计数 = 0
长度 = 取文本长度 (Skey)
.判断循环首 (计数 < 长度)
    基值 = 基值 + 左移 (基值, 5) + 取代码 (Skey, 计数 + 1)
    计数 = 计数 + 1
.判断循环尾 ()
结果 = 位与 (基值, 2147483647)
返回 (到文本 (结果))

function getBKN(str){ 
   var hash = 5381; 
   for(var i = 0, len = str.length; i < len; ++i) 
   { 
   hash += (hash << 5) + str.charAt(i).charCodeAt(); 
   } 
   return hash & 0x7fffffff; 
}

源码截图

QQ图片20221106034217.png
QQ图片20221106034239.png

源码下载

skey和pskey获取

点亮CF图标 在 vip.qq.com 获取
查询指定QQ群资料 在 qun.qq.com 获取

使用说明

解压压缩包里面的两个文件到网站目录
查询指定QQ群资料 文件里面有说明
点亮QQ手机端CF图标 文件里面有说明

查询指定QQ群资料 填写过skey和pskey值之后 可以实现免密查询QQ群资料

1
打赏

海报

正在生成.....

♥评论♥(10)

使用cookie技术保留您的个人信息以便您下次快速评论,继续评论表示您已同意该条款
取消
  1. 头像
    学习学习,支持支持大佬
    四川省成都市电信
    Windows 10 Windows 10 / Google Chrome 121 Google Chrome 121
    沙发

    学习学习,支持支持大佬

    Windows 10 Windows 10 / Google Chrome 121 Google Chrome 121
    回复
  2. 头像
    666
    浙江省宁波市移动
    Windows 10 Windows 10 / QQ 浏览器 11 QQ 浏览器 11
    板凳

    支持

    Windows 10 Windows 10 / QQ 浏览器 11 QQ 浏览器 11
    回复
  3. 头像
    season
    吉林省长春工业大学
    Mac OS X 10.15.7 Mac OS X 10.15.7 / Safari 16 Safari 16
    地毯

    有没有自动更新skey的方法,最近想做一个抓群成员的🤔️

    Mac OS X 10.15.7 Mac OS X 10.15.7 / Safari 16 Safari 16
    回复
    1. 头像
      苏晓晴
      广西贺州市移动
      博主
      Windows 11 Windows 11 / Microsoft Edge 113 Microsoft Edge 113
      @ season

      没有呢

      Windows 11 Windows 11 / Microsoft Edge 113 Microsoft Edge 113
      回复
  4. 头像
    kaikai
    广东省移动
    Windows 10 Windows 10 / Google Chrome 86 Google Chrome 86
    第4楼

    坎坎坷坷

    Windows 10 Windows 10 / Google Chrome 86 Google Chrome 86
    回复
  5. 头像
    3189402257
    移动
    ViVO Y30 / Android 10 Android 10 / Google Chrome 83 Google Chrome 83
    第5楼

    支持!!!

    Android 10 Android 10 / Google Chrome 83 Google Chrome 83
    回复
  6. 头像
    河南省南阳市移动
    荣耀 X10 / HarmonyOS HarmonyOS / 华为浏览器 12 华为浏览器 12
    第6楼

    感谢分享

    HarmonyOS HarmonyOS / 华为浏览器 12 华为浏览器 12
    回复
  7. 头像
    [a'のby冥
    四川省遂宁市移动
    Windows 10 Windows 10 / QQ 浏览器 11 QQ 浏览器 11
    第7楼

    不知道我的封号了能不能点亮

    Windows 10 Windows 10 / QQ 浏览器 11 QQ 浏览器 11
    回复
  8. 头像
    757442495
    山西省长治市联通
    Windows 10 Windows 10 / Google Chrome 107 Google Chrome 107
    第8楼

    学习学习

    Windows 10 Windows 10 / Google Chrome 107 Google Chrome 107
    回复
  9. 头像
    腾讯视频
    山东省枣庄市联通
    Windows 10 Windows 10 / Google Chrome 107 Google Chrome 107
    第9楼

    厉害

    Windows 10 Windows 10 / Google Chrome 107 Google Chrome 107
    回复